Daily betfair mappings not being updated

0 votes
Hi,

The same issue has resurfaced with no betfair mappings available.

I can see from Windows Task scheduler that the latest updates have been run, but the betfair mappings table hasn't been updated.

The daily_races_beta and daily_runners_beta updates have come through fine.

Is there anything speciifc in my local install I should be looking for with regards to betfair mappings table?
related to an answer for: betfair_mappings table
asked Jun 16 in Automatic Exchange Betting by chakradharmn Novice (230 points)

1 Answer

0 votes
 
Best answer

Hi - all the betfair mappings for today are available.

What is likely to have happened here is that we had to update the table yesterday morning, and your last fetch of data probably occurred before that update.  This means it is out of sync.

To resync, simply delete the last day or two of entries and re-run daily_betfair_mappings.

Eg: within the Smartform database, run:

delete from daily_betfair_mappings where date=curdate();

Then, run the smartform-updater from the system command line, thus:

smartform-updater daily_betfair_mappings


This issue may occur from time to time, since creating the mappings relies on calling the Betfair API and it being up and running, amongst other things.

Hope this helps, any issues let us know.

answered Jun 16 by colin Frankel (16,980 points)
selected Jul 1 by colin
Cheers, that works.

small tweak; delete from daily_betfair_mappings where date=curdate() -1;

Looks like there is an issue with Nan's on betfair race_id's for yesteday.
Yes - that was for Royal Ascot, which is why we had to rerun them.  If you caught the earlier version you'd have had those missing in your first data download, but the new updater should have cleaned things up provided they were deleted.
This does not work for me. I tried running that command from WorkBench, but get

Error Code: 1175. You are using safe update mode and you tried to update a table without a WHERE that uses a KEY column.
 To disable safe mode, toggle the option in Preferences -> SQL Editor and reconnect.    0.000 sec
As the error suggested, you need to disable safe mode (it can be found in edit>preferences>sql editor)

It worked for me after I had done that.
...